SD card mount issues

Update: 2x vigil cameras for the moment seem to be working fine with 64GB SanDisk SD cards, however, these only seem to record ~3days of video. These cards are formatted FAT32. New 128GB SD cards can only be formatted to exFAT and my camera doesn’t even recognize a card is present. I’m prepared to try an NTFS format, but am I wasting my time. I’d prefer to avoid unnecessarily going 2m up a ladder to change out an SD card that isn’t going to work. Anyone with any sage words of advice?

Hi Paul, all of my 128gb Sandisk cards are formatted exfat and are recognised immediately. Unless camera is restarted by Netvue after a firmware update. If this happens I have to remove card and format it on my laptop. Alas this situation sometimes corrupts the card and renders it useless.

Just to point out guys.

You must insert card when the cam is off. Failure to do this will burn card CPU and life will be very short!

2 Likes

Hello
Same problem with sandisk card 128. No card detected.
Firmware 1565…
Any solution ?
Thank you very much
Pierrick

Hello same problem here, working well from months and now sd card is out.

Hi Pierrick,

please make sure you’ve inserted SD card in a right way:

Q: The correct way to insert SD card?

  1. Make sure there is nothing in the SD card that you need to backup
  2. Cut off your device power
  3. Insert SD Card (Class-10; 32-128GB)
  4. Connect Power
  5. Access"Replay" page of your device, you might need to format it

Q: No card is displayed in the APP after it is inserted?

  1. Make sure you’ve insert the SD card correctly according to the above process
  2. Power off and restart the camera
  3. If still fill, try again with another SD card

Hi Rcorredera,

could you please try to format SD card?

Getting quite fed up now … I have no idea if these incidents are related …
May camera firmware was upgraded whilst 64GB (FAT32) SD cards were fitted.
All was working well and historical video was being successfully recorded. (Up to about 60hrs)
But all attempts to upgrade to 128GB cards has failed. No matter what pre-formatting tricks I try the new cards are simply no recognized, the camera wont format or mount them …
Yes, the new cards are SanDisk. Yes they’re class 10, SDXC. Yes my PC recognizes these cards as being both present and formatted.

I have 2 vigil 2 cameras. One was having problem with the SD not mounted every day or two. I bought a new Sandisk 128G SD and it would say no SD. I finally figured out I had to format as FAT32. exFAT does not work in my cameras. Windows does not have the ability to format in FAT32 anymore, so you need to install a free disk partition tool. I tried formatting a working SD as exFAT and camera said no SD. Needs to be FAT32.

Nice work ed24 ~ FAT32 is clearly the way to go. Just formatted a 128GB SD card with FAT32. When inserted into Vigil camera it was immediately mounted, no further set-up was required. Great call, thank you. My second camera will be similar upgraded once this has been running for a few days.

Same problem with the good process and 3 different brands of rich is Sandisk. The same problem on my 5 orbi cam…
I think the problem is more the firmware…
Thank you
Pierrick

Thanks for the solution but still disappointed with the support offered by Netvue.
They have always worked and now we all have the same problem together.
It is clear that they point to the cloud and it is certainly not a hardware problem (microsd) but rather some ad hoc firmware changes.
The only solution is an urgent revision of the firmware or to go back to previous versions.

Hi Marceobeo,

Would you like to update your 7016 or 2034 devices to firmware 1568? Many customers have solved this problem via this firmware version.

Hi Paul,

Could you please send the device ID that can not recognise SD card?

Hi Pierrick,

Could you please send the device ID that can not recognise SD card?

Envoyé de mon iPhone

Since around Feb 20th, two of my SD cards failed to mount. This happens occasionally and normally I can just format the card and it starts working again. I figured maybe it was the sd card, but both porch cameras quit at the exact same time, too much of a coincidence. I tried other sd cards from my other cameras and those worked so I thought maybe it was the SD card. So I purchased 2 NEW SD cards… the cameras then wouldn’t even READ the card, it said “No SD CARD”, so I couldn’t even format it. I then tried formatting it on my computer but it still didn’t work. I even put them in my other cameras but nothing. Then I returned those SD cards and purchased 2 other ones, a different brand this time. Then I thought, maybe it’s the camera. BUT it wasn’t because my other sd cards worked fine. ANYWAY, Netvue support was NO help. Somebody here mentioned formatting to fat32 but when I tried, I kept getting an error of “volume is too big for fat32” and I had so many problems finding a free fat32 formatting tool so I found a video where someone posted commands for creating a primary partition via command prompt as administrator. I still don’t quite understand it but I just followed these exact steps and I was able to format my 128gb microSD card.

  1. Open command prompt as administrator
  2. Diskpart
  3. List disk
  4. Select disk X (where X is the disk that you want to partition/format)
  5. Clean
  6. Create partition primary size=30000 (where 30,000 is the primary size in MB you want the partition to be, under 32gb)
  7. Select partition 1
  8. Active
  9. Format quick fs=fat32
  10. Assign
  11. Exit

And now my SD cards are mounted and work! Oh, also… when they mounted, they mounted as 32gb. So I just formatted within the app, then it was able to show the true size as 128gb.

Easy peasy. I hope this continues to work. I will be back to update if things go bad. I’m almost positive it had to have been a firmware update that caused this error. Too many people with the same problem is not just a coincidence.

1 Like

Looking forward to any future updates Panthera!
Are your cameras installed internal or externally?
It concerns me that we’re having to find work-arounds at all.
exFAT (the de-facto standard for any SD card greater than 32gb) appears to be a non-starter.
No matter which file system is employed the MTBF is also appallingly low.
I employed a similar formatting technique and the card failed after just 4 days …

Paul, are you asking if I have mine installed indoor vs outdoor? I have 5 indoor HomeCams and 5 outdoor Vigil Cams (and one extra that is not in use). I was told they are discontinuing the HomeCam so I got an extra incase. I really like the HomeCam 1080p. The video quality seems so much better than the outdoor VigilCam.

What problem were you having? Not mounting or SD card not even getting recognized? So after 4 days the problem returned? It is very frustrating having to be our own IT as if we are beta testers. I have spent a lot on these cameras and I refuse to use the cloud service. Another thing I noticed recently is once my card is full, it no longer rewrites itself like it used to. Now it just stops recording all together and unmounts until I format. Before it was nice when it would just rewrite all on it’s own.

HOW TO: Format SD Card To FAT32 | Win 10/8.1/8/7/Vista | TUTORIAL - YouTube